Inventory API Outage
Incident Report for The Edmunds API and Widgets
Resolved
The Inventory API is now working as expected.
Posted about 4 years ago. Dec 30, 2014 - 12:41 PST
Investigating
An investigation has begun..
Posted about 4 years ago. Dec 30, 2014 - 12:16 PST